Instalador antena WiFi USB TP-LINK TL-WN722N para Linux

See in ENGLISH

NOTA: Este Script ha sido probado en Canaima GNU/Linux 3.0 y 3.1 (Debian Squeeze) pero en teoría debería ser válido para la mayoría de las distribuciones.

Hace ya un tiempo que vengo peleando con linux y mi antena WiFi  TP-LINK TL-WN722N, porque cada vez que se me actualiza el kernel o hago una nueva instalación de Linux se desactiva la wifi ya que el kernel no posee los drivers.

Es por esto que me he decidido a automatizar el proceso y a la vez ayudar a quienes tengan el mismo problema que yo con esta antena.

He desarrollado una pequeño programa de consola que hace todo el proceso de instalación y lo único que hay que hacer es insertar la antena una vez finalizado el proceso. Es de notar que lo he desarrollado en idioma ingles ya que es posible que sea útil no solo a los usuarios de habla española sino también de otras partes del planeta.

El código fuente del programa es totalmente libre y lo puedes encontrar aquí:

https://github.com/erickcion/tlwn722n-linux-install

Si sólo quieres descargar la última versión actualizada utiliza este enlace:

DescargarDescargar la versión más actual

Para ejecutarlo solo descomprime el paquete que descargaste y en la consola dirígete a la carpeta descomprimida. Luego le das permisos de ejecución al script y ejecutas “install.sh” como root y la fiesta debería comenzar… ejemplo:

$ cd nombre_carpeta_descomprimida
$ chmod +x ./install.sh
$ su root -c ./install.sh

Si tienes algún problema, sugerencia o comentario estaré agradecido de recibirlo.

Acá te dejo una lista de otros dispositivos soportados por módulo “ath9k_htc” en Linux

Espero te sea útil.

About these ads

152 pensamientos en “Instalador antena WiFi USB TP-LINK TL-WN722N para Linux

  1. marco tami dice:

    amigo estoy un poco enreado con estoy soy nuevo en esto y no se como ejecutar el programa

  2. janfergrim dice:

    hola erick primero y antes que nada felicitarte y agradecerte por tu desinteresado aporte a la comunidad, luego te comento tengo una antena TL- WIN 721N al instalarla no me dio error alguno, ya la conecte pero no aparece por ningún lado no se si hay que hacer algo mas para que reconozca la antena, de antemano te quedo muy agradecido

    • erickcion dice:

      ¿Si no la ves por ningún lado como sabes que no te dio error?… ¿qué sistema estas usando y en que versión?

      • janfergrim dice:

        La instalación no dio error, uso Ubunto Ultimate 2.6.24-19-generic

      • saludo viejo, felicidades hace un buen trabajo.
        hombre deseo que me ayude con este problema, quiero ponerle a mi laptop una antenita como la TP-link: TL-WN7200ND ó la TLWN8200ND el problema es la instalación de estos aparatos, he tratado de compilar tu script y resolver los problemas que se me presentaron en la compilación peor no tuve éxito. la terminal me tira esto:
        _____________________________________________
        # ./install.sh

        Installing firware…

        Changing to directory “compat-drivers-source”…
        Trying to select the ath9k_htc diver to be compiled…
        Processing new driver-select request…
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: drivers/net/wireless/Makefile.bk
        Backup exists: drivers/net/wireless/ath/Makefile.bk
        Backup exists: net/wireless/Makefile.bk
        Backup exists: drivers/ssb/Makefile.bk
        Backup exists: drivers/bcma/Makefile.bk
        Backup exists: drivers/misc/eeprom/Makefile.bk
        Backup exists: Makefile.bk
        Compiling modules…
        make -C /lib/modules/3.2.0-60-generic-pae/build M=/home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source modules
        make[1]: se ingresa al directorio «/usr/src/linux-headers-3.2.0-60-generic-pae»
        CC [M] /home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/compat/main.o
        In file included from /home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-2.6.h:67:0,
        from :0:
        /home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-3.4.h:43:21: error: redefinición de ‘kmalloc_array’
        include/linux/slab.h:243:21: nota: la definición previa de ‘kmalloc_array’ estaba aquí
        In file included from /home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-2.6.h:71:0,
        from :0:
        /home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-3.8.h:48:32: error: redefinición de ‘kref_get_unless_zero’
        include/linux/kref.h:47:32: nota: la definición previa de ‘kref_get_unless_zero’ estaba aquí
        make[3]: *** [/home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/compat/main.o] Error 1
        make[2]: *** [/home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source/compat] Error 2
        make[1]: *** [_module_/home/alejandro/tlwn722n-linux-install-latest/compat-drivers-source] Error 2
        make[1]: se sale del directorio «/usr/src/linux-headers-3.2.0-60-generic-pae»
        make: *** [modules] Error 2
        There was a problem compiling the package.

        #
        ____________________________________________

        seria de gran ayuda algunas recomendaciones, mi sistema operativo es kubuntu 12.04 LTS.

      • erickcion dice:

        Saludos Alejandro, tienes un kernel 3.2 por lo cual no necesitas instalar el script, lo unico que necesitas es instalar el paquete “firmware-atheros” buscalo en el synaptic o ejecuta este comando:

        aptitude install firmware-atheros

      • Saludos erik

        Haber hombre creo que estamos hablando en diferente lengua, me explico mejor, lo que pasa es que mi controlador inalámbrico en mi pc funciona correctamente yo no tengo problema alguno con eso es decir, mi computadora detecta señales sin problema y me puedo conectar y navegar por la red sin problemas, lo que sucede es que mi interés es poder utilizar una antena externa que están en le mercado como por ejemplo las
        tp-link tl-wn7200nd ó tp-link tl-wn7200nd que es un dispositivo al parecer solo con soporte para windows y pues por lo tanto no me lo reconoce mi sistema, es por eso que quiero que me eches una mano con esto si es que es esto lo que trata esta web.

      • erickcion dice:

        Probablemente lo que necesites es agregar algun firmware o un módulo, para saberlo. Es poco lo que te puedo ayudar con ese modelo porque no tengo uno a la mano para probarlo.

        http://niparasc.blogspot.com/2012/07/how-to-install-tp-link-tl-wn7200nd-in.html

      • mmmm muy bien, hombre gracias por la atención y su tiempo prestado. (Y)

  3. rood dice:

    Amigo si pude instalarlo, pero no me puedo conectar a la red solo la detecta, alguna sugerencia?

  4. angel dice:

    hola, erickcion tengo una lapto caimanita que nesecito conectarle la antena TP-LINK TL-WN7200ND para tener internet. como lo haria. por favor una orientacion te lo agradezco

  5. Julio Arévalo dice:

    Buen día erickcion, ante todo mi saludo y bueno darte las gracias por tu aporte, personas como tú ayudan mucho a la comunidad y bueno eso se agradece. me funcionó perfectamente la instalación. Pero queria preguntarte como hacer para desintalar el controlador de la tarjeta WiFi USB TP-LINK TL-WN722N, ya que la que instalé ya no la voy a necesitar en el equipo porque compre un router unalambrico y la señal llega mejor al sitio. pero al quitar la antena se desactiva la antena inalambrica que trae interna la canaimita.

    En fin, lo que deseo es activar la otra antena que trae la canaimita. mil gracias.

    • erickcion dice:

      Desde la terminal entra en la carpeta llamada “compat-drivers-source” que esta dentro del paquete y ejecuta:

      su root -c “make uninstall”

    • Julio Arévalo dice:

      Buenas tardes hermano, ejecuté los comandos como lo mandaste y en primera parte sale como si estuviera eleminando unos archivos, tarda mas o menos unos 15 minutos y al final no hace nada, la antena tpl sigue estando en funcionamiento y la interna no se activa. Reinicié el computador varias veces y nada. Tengo algunas fotos de la pantalla no se si te las puedo mandar a un correo en específico.

  6. ronys dice:

    buenas tarde lo ejecute pero me parece un error en make por facor que debo hacer estoy trabajando en una canaimita

  7. hermano, necesito de su ayuda para instalar Tp-link Tl-wn722n sera que puede dar los pasos para poder instalar el adaptador usb. por favor mi correo es darwinjpnc@gmail.com, cualquiera que lo halla hecho por favor ayuda.

  8. Alejandro dice:

    Lo hago desde ubuntu, hice como dices, usando sudo ./install.sh
    Corrió pero salió un error
    Installing firware…

    Changing to directory “compat-drivers-source”…
    Trying to select the ath9k_htc diver to be compiled…
    Processing new driver-select request…
    Backing up makefile: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backing up makefile: drivers/net/wireless/Makefile.bk
    Backing up makefile: drivers/net/wireless/ath/Makefile.bk
    Backing up makefile: net/wireless/Makefile.bk
    Backing up makefile: drivers/ssb/Makefile.bk
    Backing up makefile: drivers/bcma/Makefile.bk
    Backing up makefile: drivers/misc/eeprom/Makefile.bk
    Backup exists: Makefile.bk
    Compiling modules…
    ./scripts/gen-compat-autoconf.sh /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/.config /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/config.mk > include/linux/compat_autoconf.h
    make -C /lib/modules/3.5.0-34-generic/build M=/home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source modules
    make[1]: se ingresa al directorio «/usr/src/linux-headers-3.5.0-34-generic»
    CC [M] /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/compat/main.o
    In file included from /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-2.6.h:71:0,
    from :0:
    /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-3.8.h:48:32: error: redefinición de ‘kref_get_unless_zero’
    In file included from include/linux/kobject.h:24:0,
    from include/linux/slub_def.h:13,
    from include/linux/slab.h:185,
    from include/linux/textsearch.h:8,
    from include/linux/skbuff.h:28,
    from include/linux/if_ether.h:134,
    from include/linux/netdevice.h:29,
    from /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-2.6.29.h:5,
    from /home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/include/linux/compat-2.6.h:52,
    from :0:
    include/linux/kref.h:113:32: nota: la definición previa de ‘kref_get_unless_zero’ estaba aquí
    make[3]: *** [/home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/compat/main.o] Error 1
    make[2]: *** [/home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source/compat] Error 2
    make[1]: *** [_module_/home/ajenandro/Descargas/tlwn722n-linux-install-latest/compat-drivers-source] Error 2
    make[1]: se sale del directorio «/usr/src/linux-headers-3.5.0-34-generic»
    make: *** [modules] Error 2
    There was a problem compiling the package.

  9. Alejandro dice:

    Hola. Me pide una contraseña
    ajenandro@ajenandro-Rev-1-0:~/Descargas/tlwn722n-linux-install-latest$ su root -c ./install.sh
    Contraseña:
    ¿Qué debo hacer ahí?

  10. gabriel dice:

    amigo ayuda, eh intentado todo, no funciona. usted sabe como instalarlo en canaima, es un derivado de debian

  11. gabriel dice:

    amigo uso canaima, al final despues de mucho trabajo me sale ESTO:

    Installing firware…

    Changing to directory “compat-drivers-source”…
    Trying to select the ath9k_htc diver to be compiled…
    Processing new driver-select request…
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: drivers/net/wireless/Makefile.bk
    Backup exists: drivers/net/wireless/ath/Makefile.bk
    Backup exists: net/wireless/Makefile.bk
    Backup exists: drivers/ssb/Makefile.bk
    Backup exists: drivers/bcma/Makefile.bk
    Backup exists: drivers/misc/eeprom/Makefile.bk
    Backup exists: Makefile.bk
    make is not installed.
    Please, install make to continue.

    que es eso de make? y hice los pasos a la perfeccion

  12. yesser dice:

    hola como estas acabo de recibir mi canaima de bachillerato y ddejame decirte que haces muy buenos post me ayudo mucho el de cambiar la clave de root

    pero en este no se como hacer con esto, osea que no entiendo lo ultimo

    Para ejecutarlo solo descomprime el paquete que descargaste y en la consola dirígete a la carpeta descomprimida. Luego le das permisos de ejecución al script y ejecutas “install.sh” como root y la fiesta debería comenzar… ejemplo:

    $ cd nombre_carpeta_descomprimida
    $ chmod +x ./install.sh
    $ su root -c ./install.sh

    puedes explicarlo un poco mejor gracias :D

  13. Mauro dice:

    Hola!! Te hago una consulta, estoy queriendo comprar un adaptador de estos pero modelo 725n u 823n, crees que funcionará el parche? Muchas gracias!! Saludos!!

  14. Jorge dice:

    Gracias Erick ,después de decenas de intentos he logrado que hacer mi Tp-link wn722n funcione a las mil maravillas.
    Lo he intentado con multitud de consejos e indicaciones que hay en la red,pero ninguna de ellas logre que funcionase, cuando iba a “tirar la toalla”, encontré tus consejos.
    Cuando leí la forma de instalar la antena Tp-link, pensé que era una forma más de fracasar, ya que me parecía una instalación muy “simple”.
    Una vez que reinicie el ordenador , no me lo podía creer, el icono de wifi me decía que tenia a mi disposición una decena de señales.
    Firefox es mi navegador y utilizo una distro ubuntu llamada Guadalinex v7.
    Una vez más te reitero mi agradecimiento.
    Jorge…

  15. cristian dice:

    hola, no entiendo esta parte como hacerla: Luego le das permisos de ejecución al script y ejecutas “install.sh” como root… (soy principiante ni cambiar idioma de teclado se ) desde ya gracias.

  16. alemoia dice:

    muchas gracias!!!! me re sirvio

  17. josemiguel dice:

    Hola Erick, gracias por compartir esto. He seguido tus pasos y ha funcionado perfectamente, y era un tema que llevaba ya un tiempo arrastrando.

    Saludos

  18. PAblo dice:

    Hola Erick, tengo problemas con el instalador 1.5, instale todos los paquetes que pide, a la hora de ejecutar ./install.sh me salta esto, ayuda! gracias!

    able_drv_get_rssi’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1262: error: implicit declaration of function ‘register_trace_drv_get_rssi’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_drv_get_rssi’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1262: error: implicit declaration of function ‘unregister_trace_drv_get_rssi’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1293: error: redefinition of ‘trace_drv_mgd_prepare_tx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1288: error: previous definition of ‘trace_drv_mgd_prepare_tx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1321: error: redefinition of ‘trace_drv_add_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1317: error: previous definition of ‘trace_drv_add_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1327: error: redefinition of ‘trace_drv_remove_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1323: error: previous definition of ‘trace_drv_remove_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_drv_change_chanctx’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1329: error: implicit declaration of function ‘register_trace_drv_change_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_drv_change_chanctx’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1329: error: implicit declaration of function ‘unregister_trace_drv_change_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1384: error: redefinition of ‘trace_drv_assign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1379: error: previous definition of ‘trace_drv_assign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1391: error: redefinition of ‘trace_drv_unassign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1386: error: previous definition of ‘trace_drv_unassign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_drv_start_ap’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1393: error: implicit declaration of function ‘register_trace_drv_start_ap’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_drv_start_ap’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1393: error: implicit declaration of function ‘unregister_trace_drv_start_ap’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1428: error: redefinition of ‘trace_drv_stop_ap’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1424: error: previous definition of ‘trace_drv_stop_ap’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1433: error: redefinition of ‘trace_drv_restart_complete’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1430: error: previous definition of ‘trace_drv_restart_complete’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_start_tx_ba_session’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1439: error: implicit declaration of function ‘register_trace_api_start_tx_ba_session’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_start_tx_ba_session’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1439: error: implicit declaration of function ‘unregister_trace_api_start_tx_ba_session’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_start_tx_ba_cb’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1460: error: implicit declaration of function ‘register_trace_api_start_tx_ba_cb’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_start_tx_ba_cb’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1460: error: implicit declaration of function ‘unregister_trace_api_start_tx_ba_cb’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_stop_tx_ba_session’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1483: error: implicit declaration of function ‘register_trace_api_stop_tx_ba_session’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_stop_tx_ba_session’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1483: error: implicit declaration of function ‘unregister_trace_api_stop_tx_ba_session’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_stop_tx_ba_cb’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1504: error: implicit declaration of function ‘register_trace_api_stop_tx_ba_cb’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_stop_tx_ba_cb’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1504: error: implicit declaration of function ‘unregister_trace_api_stop_tx_ba_cb’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1530: error: redefinition of ‘trace_api_restart_hw’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1527: error: previous definition of ‘trace_api_restart_hw’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_beacon_loss’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1532: error: implicit declaration of function ‘register_trace_api_beacon_loss’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_beacon_loss’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1532: error: implicit declaration of function ‘unregister_trace_api_beacon_loss’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_connection_loss’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1551: error: implicit declaration of function ‘register_trace_api_connection_loss’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_connection_loss’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1551: error: implicit declaration of function ‘unregister_trace_api_connection_loss’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_cqm_rssi_notify’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1570: error: implicit declaration of function ‘register_trace_api_cqm_rssi_notify’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_cqm_rssi_notify’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1570: error: implicit declaration of function ‘unregister_trace_api_cqm_rssi_notify’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_scan_completed’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1592: error: implicit declaration of function ‘register_trace_api_scan_completed’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_scan_completed’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1592: error: implicit declaration of function ‘unregister_trace_api_scan_completed’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_sched_scan_results’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1613: error: implicit declaration of function ‘register_trace_api_sched_scan_results’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_sched_scan_results’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1613: error: implicit declaration of function ‘unregister_trace_api_sched_scan_results’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_sched_scan_stopped’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1631: error: implicit declaration of function ‘register_trace_api_sched_scan_stopped’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_sched_scan_stopped’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1631: error: implicit declaration of function ‘unregister_trace_api_sched_scan_stopped’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_sta_block_awake’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1649: error: implicit declaration of function ‘register_trace_api_sta_block_awake’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_sta_block_awake’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1649: error: implicit declaration of function ‘unregister_trace_api_sta_block_awake’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_chswitch_done’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1673: error: implicit declaration of function ‘register_trace_api_chswitch_done’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_chswitch_done’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1673: error: implicit declaration of function ‘unregister_trace_api_chswitch_done’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1697: error: redefinition of ‘trace_api_ready_on_channel’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1694: error: previous definition of ‘trace_api_ready_on_channel’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1702: error: redefinition of ‘trace_api_remain_on_channel_expired’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1699: error: previous definition of ‘trace_api_remain_on_channel_expired’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_gtk_rekey_notify’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1704: error: implicit declaration of function ‘register_trace_api_gtk_rekey_notify’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_gtk_rekey_notify’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1704: error: implicit declaration of function ‘unregister_trace_api_gtk_rekey_notify’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_enable_rssi_reports’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1725: error: implicit declaration of function ‘register_trace_api_enable_rssi_reports’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_enable_rssi_reports’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1725: error: implicit declaration of function ‘unregister_trace_api_enable_rssi_reports’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_api_eosp’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1749: error: implicit declaration of function ‘register_trace_api_eosp’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_api_eosp’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1749: error: implicit declaration of function ‘unregister_trace_api_eosp’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_wake_queue’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1776: error: implicit declaration of function ‘register_trace_wake_queue’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_wake_queue’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1776: error: implicit declaration of function ‘unregister_trace_wake_queue’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_enable_stop_queue’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1800: error: implicit declaration of function ‘register_trace_stop_queue’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: In function ‘ftrace_profile_disable_stop_queue’:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1800: error: implicit declaration of function ‘unregister_trace_stop_queue’
    In file included from /usr/src/linux-headers-2.6.32-5-common/include/trace/ftrace.h:636,
    from /usr/src/linux-headers-2.6.32-5-common/include/trace/define_trace.h:61,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/include/trace/define_trace.h:4,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/trace.h:1868,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/trace.c:10:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h: At top level:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:139: error: redefinition of ‘trace_drv_return_void’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:136: error: previous definition of ‘trace_drv_return_void’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:187: error: redefinition of ‘trace_drv_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:184: error: previous definition of ‘trace_drv_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:192: error: redefinition of ‘trace_drv_get_et_strings’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:189: error: previous definition of ‘trace_drv_get_et_strings’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:197: error: redefinition of ‘trace_drv_get_et_sset_count’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:194: error: previous definition of ‘trace_drv_get_et_sset_count’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:202: error: redefinition of ‘trace_drv_get_et_stats’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:199: error: previous definition of ‘trace_drv_get_et_stats’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:207: error: redefinition of ‘trace_drv_suspend’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:204: error: previous definition of ‘trace_drv_suspend’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:212: error: redefinition of ‘trace_drv_resume’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:209: error: previous definition of ‘trace_drv_resume’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:231: error: redefinition of ‘trace_drv_stop’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:228: error: previous definition of ‘trace_drv_stop’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:237: error: redefinition of ‘trace_drv_add_interface’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:233: error: previous definition of ‘trace_drv_add_interface’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:271: error: redefinition of ‘trace_drv_remove_interface’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:267: error: previous definition of ‘trace_drv_remove_interface’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:545: error: redefinition of ‘trace_drv_hw_scan’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:541: error: previous definition of ‘trace_drv_hw_scan’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:551: error: redefinition of ‘trace_drv_cancel_hw_scan’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:547: error: previous definition of ‘trace_drv_cancel_hw_scan’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:557: error: redefinition of ‘trace_drv_sched_scan_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:553: error: previous definition of ‘trace_drv_sched_scan_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:563: error: redefinition of ‘trace_drv_sched_scan_stop’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:559: error: previous definition of ‘trace_drv_sched_scan_stop’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:568: error: redefinition of ‘trace_drv_sw_scan_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:565: error: previous definition of ‘trace_drv_sw_scan_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:573: error: redefinition of ‘trace_drv_sw_scan_complete’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:570: error: previous definition of ‘trace_drv_sw_scan_complete’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:634: error: redefinition of ‘trace_drv_set_frag_threshold’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:631: error: previous definition of ‘trace_drv_set_frag_threshold’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:639: error: redefinition of ‘trace_drv_set_rts_threshold’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:636: error: previous definition of ‘trace_drv_set_rts_threshold’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:839: error: redefinition of ‘trace_drv_get_tsf’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:835: error: previous definition of ‘trace_drv_get_tsf’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:870: error: redefinition of ‘trace_drv_reset_tsf’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:866: error: previous definition of ‘trace_drv_reset_tsf’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:875: error: redefinition of ‘trace_drv_tx_last_beacon’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:872: error: previous definition of ‘trace_drv_tx_last_beacon’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1066: error: redefinition of ‘trace_drv_cancel_remain_on_channel’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1063: error: previous definition of ‘trace_drv_cancel_remain_on_channel’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1123: error: redefinition of ‘trace_drv_tx_frames_pending’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1120: error: previous definition of ‘trace_drv_tx_frames_pending’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1128: error: redefinition of ‘trace_drv_offchannel_tx_cancel_wait’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1125: error: previous definition of ‘trace_drv_offchannel_tx_cancel_wait’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1250: error: redefinition of ‘trace_drv_release_buffered_frames’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1242: error: previous definition of ‘trace_drv_release_buffered_frames’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1260: error: redefinition of ‘trace_drv_allow_buffered_frames’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1252: error: previous definition of ‘trace_drv_allow_buffered_frames’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1293: error: redefinition of ‘trace_drv_mgd_prepare_tx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1288: error: previous definition of ‘trace_drv_mgd_prepare_tx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1321: error: redefinition of ‘trace_drv_add_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1317: error: previous definition of ‘trace_drv_add_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1327: error: redefinition of ‘trace_drv_remove_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1323: error: previous definition of ‘trace_drv_remove_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1384: error: redefinition of ‘trace_drv_assign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1379: error: previous definition of ‘trace_drv_assign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1391: error: redefinition of ‘trace_drv_unassign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1386: error: previous definition of ‘trace_drv_unassign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1428: error: redefinition of ‘trace_drv_stop_ap’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1424: error: previous definition of ‘trace_drv_stop_ap’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1433: error: redefinition of ‘trace_drv_restart_complete’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1430: error: previous definition of ‘trace_drv_restart_complete’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1530: error: redefinition of ‘trace_api_restart_hw’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1527: error: previous definition of ‘trace_api_restart_hw’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1697: error: redefinition of ‘trace_api_ready_on_channel’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1694: error: previous definition of ‘trace_api_ready_on_channel’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1702: error: redefinition of ‘trace_api_remain_on_channel_expired’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1699: error: previous definition of ‘trace_api_remain_on_channel_expired’ was here
    In file included from /usr/src/linux-headers-2.6.32-5-common/include/trace/ftrace.h:767,
    from /usr/src/linux-headers-2.6.32-5-common/include/trace/define_trace.h:61,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/include/trace/define_trace.h:4,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/trace.h:1868,
    from /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/trace.c:10:
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:139: error: redefinition of ‘trace_drv_return_void’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:136: error: previous definition of ‘trace_drv_return_void’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:187: error: redefinition of ‘trace_drv_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:184: error: previous definition of ‘trace_drv_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:192: error: redefinition of ‘trace_drv_get_et_strings’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:189: error: previous definition of ‘trace_drv_get_et_strings’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:197: error: redefinition of ‘trace_drv_get_et_sset_count’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:194: error: previous definition of ‘trace_drv_get_et_sset_count’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:202: error: redefinition of ‘trace_drv_get_et_stats’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:199: error: previous definition of ‘trace_drv_get_et_stats’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:207: error: redefinition of ‘trace_drv_suspend’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:204: error: previous definition of ‘trace_drv_suspend’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:212: error: redefinition of ‘trace_drv_resume’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:209: error: previous definition of ‘trace_drv_resume’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:231: error: redefinition of ‘trace_drv_stop’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:228: error: previous definition of ‘trace_drv_stop’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:237: error: redefinition of ‘trace_drv_add_interface’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:233: error: previous definition of ‘trace_drv_add_interface’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:271: error: redefinition of ‘trace_drv_remove_interface’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:267: error: previous definition of ‘trace_drv_remove_interface’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:545: error: redefinition of ‘trace_drv_hw_scan’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:541: error: previous definition of ‘trace_drv_hw_scan’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:551: error: redefinition of ‘trace_drv_cancel_hw_scan’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:547: error: previous definition of ‘trace_drv_cancel_hw_scan’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:557: error: redefinition of ‘trace_drv_sched_scan_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:553: error: previous definition of ‘trace_drv_sched_scan_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:563: error: redefinition of ‘trace_drv_sched_scan_stop’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:559: error: previous definition of ‘trace_drv_sched_scan_stop’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:568: error: redefinition of ‘trace_drv_sw_scan_start’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:565: error: previous definition of ‘trace_drv_sw_scan_start’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:573: error: redefinition of ‘trace_drv_sw_scan_complete’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:570: error: previous definition of ‘trace_drv_sw_scan_complete’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:634: error: redefinition of ‘trace_drv_set_frag_threshold’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:631: error: previous definition of ‘trace_drv_set_frag_threshold’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:639: error: redefinition of ‘trace_drv_set_rts_threshold’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:636: error: previous definition of ‘trace_drv_set_rts_threshold’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:839: error: redefinition of ‘trace_drv_get_tsf’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:835: error: previous definition of ‘trace_drv_get_tsf’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:870: error: redefinition of ‘trace_drv_reset_tsf’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:866: error: previous definition of ‘trace_drv_reset_tsf’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:875: error: redefinition of ‘trace_drv_tx_last_beacon’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:872: error: previous definition of ‘trace_drv_tx_last_beacon’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1066: error: redefinition of ‘trace_drv_cancel_remain_on_channel’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1063: error: previous definition of ‘trace_drv_cancel_remain_on_channel’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1123: error: redefinition of ‘trace_drv_tx_frames_pending’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1120: error: previous definition of ‘trace_drv_tx_frames_pending’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1128: error: redefinition of ‘trace_drv_offchannel_tx_cancel_wait’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1125: error: previous definition of ‘trace_drv_offchannel_tx_cancel_wait’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1250: error: redefinition of ‘trace_drv_release_buffered_frames’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1242: error: previous definition of ‘trace_drv_release_buffered_frames’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1260: error: redefinition of ‘trace_drv_allow_buffered_frames’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1252: error: previous definition of ‘trace_drv_allow_buffered_frames’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1293: error: redefinition of ‘trace_drv_mgd_prepare_tx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1288: error: previous definition of ‘trace_drv_mgd_prepare_tx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1321: error: redefinition of ‘trace_drv_add_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1317: error: previous definition of ‘trace_drv_add_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1327: error: redefinition of ‘trace_drv_remove_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1323: error: previous definition of ‘trace_drv_remove_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1384: error: redefinition of ‘trace_drv_assign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1379: error: previous definition of ‘trace_drv_assign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1391: error: redefinition of ‘trace_drv_unassign_vif_chanctx’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1386: error: previous definition of ‘trace_drv_unassign_vif_chanctx’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1428: error: redefinition of ‘trace_drv_stop_ap’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1424: error: previous definition of ‘trace_drv_stop_ap’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1433: error: redefinition of ‘trace_drv_restart_complete’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1430: error: previous definition of ‘trace_drv_restart_complete’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1530: error: redefinition of ‘trace_api_restart_hw’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1527: error: previous definition of ‘trace_api_restart_hw’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1697: error: redefinition of ‘trace_api_ready_on_channel’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1694: error: previous definition of ‘trace_api_ready_on_channel’ was here
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1702: error: redefinition of ‘trace_api_remain_on_channel_expired’
    /home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/./trace.h:1699: error: previous definition of ‘trace_api_remain_on_channel_expired’ was here
    make[5]: *** [/home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211/trace.o] Error 1
    make[4]: *** [/home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source/net/mac80211] Error 2
    make[3]: *** [_module_/home/blooopa/Desktop/tlwn722n-linux-install-1.5/compat-drivers-source] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-686′
    make: *** [modules] Error 2
    There was a problem compiling the package.

  19. Pedro dice:

    si pudieras ser un poco mas explicativo,yo de linux no se nada explicame con lujo de detalles

  20. Hugox dice:

    Muchas Gracias, Probado en Trisquel 6 (Linux Libre 3.2) y funciono a la perfección …

  21. gonzalo dice:

    Listo! Por si a alguien le ha sucedido lo mismo (yo uso ubuntu 10.04):

    Se descargan nuevamente los módulos wireless que vienen por defecto (esto servirá unicamente si la tarjeta fue reconocida y funcionó al instalar ubuntu)

    sudo apt-get update
    sudo apt-get install linux-backports-modules-wireless-lucid-generic
    sudo reboot

    Al hacer esto perdemos nuevamente a la tp-link, pero bueno…

    Si encuentro la forma de instalar ambas, por aquí andaré.

    Lo importante es que el script funciona a la perfección!

    Gracias!

  22. gonzalo dice:

    Funciona de maravilla! Instalé una tp-link wn721n y funcionó sin problemas. Pero…… me desapareció la placa de mi notebook Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01). Tendrás idea de cómo reinstalarla??? Supuse que podrían convivir ambas, pero parece que suspuse mal!! jajajaja!! Muchas gracias!!

  23. David Escalona dice:

    Hola sera que este instalador me funciona para tplink tlwn7200nd

  24. KEN dice:

    Tengo el canaima educativo ( la canaima 3 ) he seguido todos los pasos y nada, lo que me extraña es q al insertar la antena TL-WN722N no aparece nada, por decir cuando insertas un dispositivo usb ejemplo un pendrive. ejecuto la consola como root pero me dice que el directorio no existe. Al ejecutar script abre una consola x menos de 1 segundo y se cierra y no pasa nada. Que estare haciendo mal. Gracias de antemano y saludos…

  25. marcos montoya dice:

    hermano yo distribuyo internet via wifi y ultimamente por donde vivo los vecinos me han pregutado por el servicio de internet para las canaimitas de los niños quiero hacerles las conexiones a un inmejorable precio de 35 bs mensual para el disfrute del servicio pero me encuentro en un problema que para las canaimas que se encuentran mas alejadas de la torre no hay un buen servicio que debo hacer para conectralas gracias espero su pronta respuesta…

    • erickcion dice:

      Marcos debo serte sincero, el dispositivo WiFi que viene integrado en las canaimitas no es de alta recepción e incluso la estabilidad de la señal recibida varía frecuentemente. Eso en lo referente a Hardware.

      Para solventar esto te recomiendo que utilices antenas de alta ganancia como por ejemplo la TP-LINK que aquí en este post indico cómo poner a funcionar en Canaima, la cual la he probado y mejora increiblemente la estabilidad de la señal en comparación con la que ya tiene integrada la canaimita.

      Sin embargo en a nivel de software tambien hay otra causa, la cual es que las canaimitas que están actualmente en circulacion poseen una versión de su controlador para wifi un poquito desactualizada. La empresa Realtek parece haber mejorado un poco el manejo de la recepción a nivel de software en su ultima versión del controlador.

      Así que si no quieres ofrecer a tus clientes antenas para mejorar la señal, pudieras intentar ofrecer la actualización del controlador de wifi interna de la canaimita lo cual mejora un poco la recepción, pero es un poco nada más, en algunos casos la mejoría puede No notarse mucho. Para hacerlo utiliza este instalador de wifi para la canaimita que explico en este otro post:

      http://erickcion.wordpress.com/2013/01/01/instalar-wifi-canaimita-realtek-rtl819x-para-linux/

      • marcos montoya dice:

        ok yo le quiero colocar a las canaimitas tl-wn722n y antenas yagui de mas ganancias para captar mejor la señal de mi torre que debo hacer gracias por tu tiempo saludos…

      • erickcion dice:

        De antenas yagui tu debes saber más que yo, ese no es mi medio, y sobre la configuracion de la tp-link arriba en el artículo tienes los pasos a seguir.

  26. grudy21 dice:

    excelente aporte probado y funcional en canaima Linux
    Saludos

  27. adan dice:

    Hola mira ya instale el ath9k_htc-installer, luego ejecute tu script, alterminar el script me dice que el driver esta instalado, pero al insertar la antena inalambrica wn722N me aparece un breve mensaje de Red desconectado, tengo un ubuntu 12.04 LT por favor no he podido instalar, de por si no pude instalar el driver de la tarjeta de la lap y ahorita con esta tampoco no he podido.
    Espero tu ayuda de verdad

    • erickcion dice:

      Que versión de kernel posee tu sistema?, ejecuta este comando para saberlo:

      uname -r

    • erickcion dice:

      El script sólo funciona para las versiones de Kernel menores a 3.0, en este caso el tuyo es 3.2 así que es normal que no funcione.

      Cuando disponga un poco más de tiempo libre trataré de darle soporte a esas versiones del kernel.

      • Francesco dice:

        Hola Erick, has podido hacer al up-grade por Kernel 3.2….?

      • erickcion dice:

        Hola Francesco, lamentablemente he estado muy concentrado en otras cosas, espero puedan disculparme por eso.

        Sin embargo, puedo decirte que si usas Debian o algún derivado, lo único que debes hacer para que tu antena funcione es instalar el paquete “firmware-atheros”.

        Puedes instalarlo, desde la terminal, o buscándolo en el synaptic, o descargandolo desde internet para la versión de tu sistema operativo. Ya con eso funcionará perfecto y ni siquiera necesitarás descargar este script.

  28. Daniel dice:

    Buenas noches Erick estoy tratando de seguir tus pasos pero tambien un amigo me indico que debía instalar otras cosas adicionales. Te dejo una especie de log de lo arrojado por la consola con los pasos que segui:
    (todo como root)

    cd /lib/modules/2.6.32-5-686/kernel/drivers/net/wireles
    cd /lib/modules/2.6.32-5-686/kernel/drivers/net/wireless
    cd ath
    ls -l
    cd ath9k/
    ls -l
    cp -r /home/daniel/Descargas/ar9271.fw /lib/firmware
    aptitude install gcc g++ make tar wget linux-header-$(uname -r)
    aptitude install gcc g++ make tar wget linux-headers-$(uname -r)
    uname -a
    aptitude install bison
    cp -r /home/daniel/Descargas/htc_9271.fw /lib/firmware
    cd /home/daniel/Descargas/Erickcion/tlwn722n-linux-install-tlwn722n-linux-install-stable/compat-wireless-2012-05-10/
    cd scripts && ./scripts/driver-select ath9k_htc
    ./scripts/driver-select ath9k_htc
    ./driver-select ath9k_htc
    cd ..
    ./scripts/driver-select ath9k_htc
    cd ..
    ls -l
    ./scripts/driver-select ath9k_htc
    ./tlwn722n-linux-install-tlwn722n-linux-install-stable/scripts/driver-select ath9k_htc
    cd Erickcion/
    chmod +x ./install.sh
    su root -c ./install.sh

    Installing firware…

    Changing to directory “compat-wireless-2012-05-10″…
    Trying to select the ath9k_htc diver to be compiled…
    Must run ./scripts/driver-select from the compat-wireless top level directory
    Compiling modules…
    cat: /home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_version: No existe el fichero o el directorio
    cat: /home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_base_tree: No existe el fichero o el directorio
    cat: /home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_base_tree_version: No existe el fichero o el directorio
    cat: /home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_version: No existe el fichero o el directorio
    cat: /home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_version: No existe el fichero o el directorio
    /bin/sh: ./compat/scripts/gen-compat-config.sh: not found
    make: *** [/home/daniel/Descargas/tlwn722n-linux-install/compat-wireless-2012-05-10/.compat_autoconf_] Error 127
    There was a problem compiling the package.

    Ya estoy que me doy cabezazos con la pared porque no logro instalar la antena wifi… de verdad que me ha costado un mundo

    • erickcion dice:

      Daniel gracias por tu comentario, el error que reportas se debía a un problema en el contenido del paquete, ya puedes descargar de nuevo el archivo y volverlo a intentar, estoy seguro que te funcionará.

      No era necesario que hicieras todos los pasos adicionales que muestras arriba.

      Para más detalles de la causa de este error visita acá:

      https://github.com/erickcion/tlwn722n-linux-install/issues/1

      • Daniel dice:

        Muchas gracias por la aclaratoria Erick. De verdad resulto que funciona de inmediato, sin ningún tipo de problemas. Gracias por la ayuda brindada y realmente aprecio, valoro y admiro que hayas (si aplica, hayan) solucionado de manera genérica el problema, de raíz. Admiro mucho la labor de los ingenieros venezolanos y más aun del CNTI. Mas que gracias, felicidades hermano. Saludos desde Caracas, El Valle.

  29. César dice:

    Buenas noches.! O mejor dicho madrugadas. Amigos tengo Debian 6 recien instalado y me dejo sin wifi la desktop principal de mi casa, uso la antena TP-LINK TL-WN722NC que es el mismo adaptador USB Wifi de este post sino que con una base. Ahora Instalo el script y me arroja lo siguiente:

    root@Servidor:/home/usuario/Descargas/tlwn722n-linux-install-tlwn722n-linux-install-stable# su root -c ./install.sh

    Installing firware…

    Changing to directory “compat-wireless-2012-05-10″…
    Trying to select the ath9k_htc diver to be compiled…
    Must run ./scripts/driver-select from the compat-wireless top level directory
    make is not installed.
    Please, install make to continue.

    Y de alli no pasa, no se que hacer y bueno soy algo novato en Debian porque estoy dejando windows.

    Gracias, cualquier cosa mi email:
    cesarpaz1986@gmail.com

    • erickcion dice:

      Cesar, como lo dice el script, debes instalar make. Para hacerlo ejecuta en consola el comando:

      aptitude make install

      Luego de eso intenta ejecutar el script de nuevo.

      • César Paz dice:

        Hola erick, espero te encuentres bien. Bueno reintentqandolo de nuevo con debian aún no he logrado instalar ese dispositivo. Otras versiones de linux me lo reconocen automáticamente pero Debian no. Pero resulta que quiero debian porque estoy haciendo mis prácticas de servidores. Entonces, mi sistema es debian 6 de 32bits recien instalado, pues como sabes al principio estaba quedado porque no habia leido torpemente que me faltaba instalar el “make install”, una vez instalado el make, siguió el script pero esta vez se detuvo en la siguiente pantalla:

        root@server-princ:/lib/driver# su root -c ./install.sh

        Installing firware…

        Changing to directory “compat-drivers-source”…
        Trying to select the ath9k_htc diver to be compiled…
        Processing new driver-select request…
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: Makefile.bk
        Backup exists: drivers/net/wireless/Makefile.bk
        Backup exists: drivers/net/wireless/ath/Makefile.bk
        Backup exists: net/wireless/Makefile.bk
        Backup exists: drivers/ssb/Makefile.bk
        Backup exists: drivers/bcma/Makefile.bk
        Backup exists: drivers/misc/eeprom/Makefile.bk
        Backup exists: Makefile.bk
        Compiling modules…
        Changes to compat-drivers’s configuration was detected, regenerating autoconf…
        ./scripts/gen-compat-autoconf.sh /lib/driver/compat-drivers-source/.config /lib/driver/compat-drivers-source/config.mk > include/linux/compat_autoconf.h
        make -C /lib/modules/2.6.32-5-686/build M=/lib/driver/compat-drivers-source modules
        make: *** /lib/modules/2.6.32-5-686/build: No existe el fichero o el directorio. Alto.
        make: *** [modules] Error 2
        There was a problem compiling the package.

        y alli se quedó. No se que pueda ser, y agradezco ayuda de tu parte o de cualquier otro usuario que pudiese darme solución. Muchas gracias, espero por su ayuda.

    • erickcion dice:

      Cesar,

      Intenta descargarte acá la versión 1.5 del script e indicame por favor si esa te funciona bien.

      https://github.com/erickcion/tlwn722n-linux-install/tags

      • César Paz dice:

        nada… sigue igual, creo que tiene que tiene que ver con lo de las cabeceras, pero de eso no se, alguna idea?

    • erickcion dice:

      ¿Tienes instaladas las cabeceras de tu kernel?

      aptitude install linux-headers-$(uname -r)

      • César Paz dice:

        Buenas tardes, mis saludos de hermandad, estimado erick es de mi agrado escribirle que ha funcionado el script en debian, por alguna razón que desconozco anteriormente no fue posible, pero hoy he reinstalado debian x32 bits, instale el make, los headers y actualice, luego instalé le script y listo. lo demás li hizo el solo. De verdad muchisimas gracias por su aporte, también me gustaria saber si es posible que cuando apague la máquina y la encienda nuevamente lo reconocería automaticamente y de no ser asi, cómo podría lograr dicho proceso. Nuevamente gracias.

  30. [...] al éxito del anterior instalador que publiqué para automatizar la instalación de la antena WiFi TP-LINK en Linux, he decidido en [...]

  31. [...] al éxito del anterior instalador que publiqué para automatizar la instalación de la antena WiFi TP-LINK en Linux, he decidido en [...]

  32. Ivan M dice:

    Perfecto!

    Amo Linux, y gracias a personas como tu que comparten su trabajo sin fines de lucro.

    Solo lo ejecute y luego conecte y zaz reconocido !

    Gracias!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  33. vinux dice:

    excelente brother…!!! gracias por la ayuda

  34. Leinad dice:

    Hola buenas noche oye al final no me reconoce la antena y me dice fallo de autentificación

  35. Iris dice:

    Que tal Etrickcon, yo necesitaba instalar el driver para esta andena para poder entregar un proyecto en la escuela, y me funciono muy bien! :D
    El problema es q al instarlo ya no reconoce la antena inalámbrica que tiene mi laptop, la cual es una Atheros AR242x / AR542x.
    Uso Debian Wheezy con la versión del kernel 3.2.0-4-686-pae.
    Que puedo hacer??

    De antemano, muchas gracias!!

  36. Florencia Ruiz dice:

    Hola Erick muchas gracias por esto! Segui los pasos, se instalo todo ok, pero enchufo el adaptador y no pasa nada, igual que antes. No se que hacer! El mio es: adaptador USB inalambrico TL-WN721N. Que hago?

    Mil gracias, saludos
    Florencia

  37. Angel dice:

    Bufff……, ¡¡¡muchííísimas gracias !!!!. Personas como tu ayudan a hacer un mundo mejor.
    Se que te agobiamos con preguntas, pero antes de instalar con tu script lo intenté por mi cuenta entrando a la carpeta del driver que decargé anteriormente (ath9…) , y a la hora de hacer make me dió error, la verdad es que no instalé nada mas hasta el momento en ejecuté tu script, sin embargo él lo hizo correctamente y sin errores, ¿es que el script instaló herramientas de compilación??, si es así te agradecería que me dijeses cuales. Un abrazo muy fuerte y te quedo muy agradecido.

  38. kriz dice:

    ayuda esto es lo ultimo que me aparece en la consola, ayuda con este error porfa
    Processing new driver-select request…
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: drivers/net/wireless/Makefile.bk
    Backup exists: drivers/net/wireless/ath/Makefile.bk
    Backup exists: net/wireless/Makefile.bk
    Backup exists: drivers/ssb/Makefile.bk
    Backup exists: drivers/bcma/Makefile.bk
    Backup exists: drivers/misc/eeprom/Makefile.bk
    Backup exists: Makefile.bk
    Compiling modules…
    make -C /lib/modules/2.6.32-5-686/build M=/home/kriz/downloads/erickcion-tlwn722n-linux-install-54dbb8c/source/compat-wireless-2012-05-10 modules
    make[1]: se ingresa al directorio `/lib/modules/2.6.32-5-686/build’
    make[1]: *** No hay ninguna regla para construir el objetivo `modules’. Alto.
    make[1]: se sale del directorio `/lib/modules/2.6.32-5-686/build’
    make: *** [modules] Error 2
    There was a problem compiling the package.

  39. lenin dice:

    pues la fiesta ya comenzo, al parecer corrio el archivo pero sigue sin detectarme la antena!!!1

  40. Lenin dice:

    Hola voy siguiendo tus pasos, cuando doy el comando su root -c ./install.sh
    me pide una contraseña, ingreso la del administrador pero no me la acepta.
    agradecería tu apoyo.
    saludos desde mexico

  41. peterson dice:

    Buen dia soy nuevo en esto de linux (canaima) y necesito ayudar para instalar una antena TPLINK TL-WN721N, plz los pasos para instalarlos, a mi email theonepetter@gmail.com, Thnx

  42. Pjep27 dice:

    Ingeniero un excelente aporte soy TSU en informática y estoy empezando a conocer mejor el proyecto GNU/LINUX que considera usted que debo tomar en cuenta para informarme mas sobre el software libre y para desarrollar aplicaciones en este, asi como este aporte que nos a dado usted.

  43. meduag dice:

    muy buen aporte excelente compadre, desde el brasil un sludoo..

  44. carlos dice:

    no me funciono … intente instalar otra y menos pesca … !

  45. adil dice:

    gracias por la ayuda, se agradece muchisimo

  46. Bayron dice:

    Hola Erick.
    A mi me paso lo mismo que a ti pero con la diferencia que yo no Hice un programa xP, pero bueno. Acabo de instalar el paquete de archivos y salio todo bien en la instalación, pero al momento de insertar el adaptador de red el SO no me lo detecta ¡No se que abre hecho mal. Te dejo mis especificaciones.
    -Sistema operativo Ubuntu 12.04 lts
    - Adaptador de red TP-LINK modelo TL-wn722n
    Porfa ayúdame y de antemano gracias.

    PD: El S.O. simplemente no hace nada, también hice lo que decía en la guía de instalación rápida que decía algo de dejar presionado el botón QSS, pero nada :/ , Saludos.

  47. Alfaren77 dice:

    uuufff amigo, si tu puedes ayudarme seria genial… tplink720n, servirá lo que pusiste para la 721… mi distro es ubuntu 12.04… al realizar la instalación la deje conectada para ver si levantaba el controlador y efectivamente lo levanto, pero, detecta pocas redes y con poca señal, eso me dice que el controlador que se instalo no esta funcionando de buena manera… espero que me puedas ayudar y gracias.

  48. raul dice:

    hola buenos dias.. yo lo tengo virtual el wifiway.. ya me dice que mi driver ya se instalo pero aun sigo sin conectarme a internet me podrias ayudar?

  49. Carlos Ortiz dice:

    Hola mira yo acabo de comprar una de estas antenas pero la verdad nisikiera la e conectado ala compu por que yo solo la kiero para agarrar la señal de wi-fi de mi pantalla pero al conectarla ala pantalla solo me aparece : Es posible que los ajustes de coneccion del USB no sean los correctos .
    Como le puedo hacer para configurarla me podrías ayudar?

  50. gracias amigo la verdad es q funciona muy bien excelente trabajo… solo tengo una consulta; con este driver la tarjeta soporta inyeccion de paquetes? y si no es asi me podrias guiar un poco sobre como parcharlo. muchas gracias de verdad

  51. Anthony dice:

    Entro en mi contraseña de root, sino que muestra el fracaso de autentificación. ¿Qué tengo que introducir la palabra clave con la contraseña? Lo siento estoy utilizando el traductor de google.

  52. jorge dice:

    hola amigo he intentado instalar el tp-link pero me sale este error
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: drivers/net/wireless/Makefile.bk
    Backup exists: drivers/net/wireless/ath/Makefile.bk
    Backup exists: net/wireless/Makefile.bk
    Backup exists: drivers/ssb/Makefile.bk
    Backup exists: drivers/bcma/Makefile.bk
    Backup exists: drivers/misc/eeprom/Makefile.bk
    Backup exists: Makefile.bk

    instalar Make

    ayuda no se que hacer

  53. rodolfo dice:

    Ese error me da al instalar el instalador.

    make: *** /lib/modules/2.6.32-5-686/build: No existe el fichero o el directorio. Alto.
    me ayudas por favor

    • erickcion dice:

      Debes instalar las cabeceras de tu kernel, si usas debian o alguna distribución derivada ejecuta este comando como root:

      aptitude install linux-headers-$(uname -r)

      al final del proceso vuelves a intentar ejecutar el script.

      • Pedro Lopez dice:

        ejecute el script, pero al final me sale “debe instalar el make” como lo hago tengo un ubiquiti usb

      • Pedro Lopez dice:

        INSTALE LAS CABECERAS Y ME SALE ESTE ERROR
        make[2]: *** [sub-make] Error 2
        make[1]: *** [all] Error 2
        make[1]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-686′
        make: *** [modules] Error 2
        There was a problem compiling the package.
        root@canaima-popular:/home/usuario/Descargas/ubi#

      • erickcion dice:

        Pedro López la salida del error está incompleta… necesito ver que mensajes se generaron un poco antes.

        Pero no copies la salida aquí, hazlo a través de http://pastebin.com/ y me mandas solo el link por aquí para revisarlo.

  54. Carlos dice:

    Hola. Me da este error. Espero que me puedas ayudar. Gracias

    Processing new driver-select request…
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: Makefile.bk
    Backup exists: drivers/net/wireless/Makefile.bk
    Backup exists: drivers/net/wireless/ath/Makefile.bk
    Backup exists: net/wireless/Makefile.bk
    Backup exists: drivers/ssb/Makefile.bk
    Backup exists: drivers/bcma/Makefile.bk
    Backup exists: drivers/misc/eeprom/Makefile.bk
    Backup exists: Makefile.bk
    Compiling modules…
    /root/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/config.mk:213: “WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m.”
    make -C /lib/modules/2.6.21.5/build M=/root/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27 modules
    make: *** /lib/modules/2.6.21.5/build: No such file or directory. Stop.
    make: *** [modules] Error 2
    There was a problem compiling the package.

    • erickcion dice:

      Asegúrate de tener los fuentes de la versión de kernel que estas usando… si usas Debian o un derivado instalalo con:

      aptitude install linux-headers-$(uname -r)

      • Carlos dice:

        Uso un live cd de Backtrack 3. Donde tengo q estar ubicado para ejecutar eso?

      • erickcion dice:

        No importa donde lo ejecutes, solo debes asegurarte de ir a la carpeta que descomprimiste, ejecutar los comandos que están descritos y de tener las herramientas que necesarias.

  55. Oliber Garcia dice:

    Buenas noches mi hijo posee una canaima y estoy tratando de instalar el dispositivo TP-LINK TL-WN7200ND ya hize todos los pasos descritos anteriormente pero me dice que el dispositivo no esta listo, ademas el nombre que le da al dispositivo inalambrico es Ralink 802.11 n WLAN, les agradesco que me indiquen como lograr solucionarlo, muchas gracias

  56. [...] mayo, 2012 Deja un comentario Ver en ESPAÑOL NOTE: This script has been tested in Canaima GNU / Linux 3.0 (Debian Squeeze) but in theory should [...]

  57. JULIO dice:

    olvide mencionar que uso ubuntu 10.04 nose que hacer para poder usar mi adaptador usb de red inalambrica TP-LINK TL-WN722N ayuda porfavor julicva@hotmail.com

    • erickcion dice:

      Amigo ya tienes el paquete, sólo debes seguir los pasos que están descritos arriba: descomprimir el paquete, abrir la consola, dirigirte a la carpeta que descomprimiste, ejecutar el comando chmod, y luego ejecutar el install.sh (si usas ubuntu cambia el su por sudo).

      Si aun no sabes como, te recomiendo leerte un poquito mas en la web los comandos básicos de la terminal de Linux y como funciona. Luego, si tienes algún error más especifico podré ayudarte de forma más especifica.

      • saul dice:

        en ubuntu 10.04 solo tienes q realizar os pasos ants descriptos yo mismo lo comprobe

  58. JULIO dice:

    ayudaaa soy nevo usando linux descargue el programa ya que necesito usar mi antena
    tl-w722n pero nose que como instalar en el linux si alguien me pudiese ayudar mi correo es julicva@hotmail.com

  59. Excelente!, llegue al lugar correcto y pude solucionarlo, Gracias!

  60. quien dice:

    gracias

    estoy probando en ubuntu 10.04 aver que tal , tengo la misma antena usb tl-wn722n, no soy experto en linux pero si pude ejecutar la instalacion.

  61. niungo dice:

    Hola.
    Soy nuevo en esto y aun no entiendo mucho, por lo que mi problema puede ser muy tonto.
    He intentado seguir todos los pasos y solo me aparece un solo problema.
    Cuando ingreso “su root -c ./install.sh” me pide una contraseña y luego me dice:”Fallo en su autentificación”.

    Cual es el problema?
    Gracias.

    • m3ka0 dice:

      antes de ingresar los comandos indicados prueba hacerlos ingresando como root – usando el comando SUDO SU pones la contraseña y prueba..
      cuando pones SU ROOT -C ./ INSTALL l stas diciendo q lo haga como superusuario.. al poner su root n la terminal veras q t pid dos vcs la password y no es la q tu usas para iniciar sesion es la password del superusuario q x motivos de seguridad viene desahabilitada – la puedes activar con el riesgo q eso conlleva ,con el comando
      passwd root
      y escribes la contraseña q quieres,

  62. Miguel dice:

    Solicitando de su ayuda, Erick:
    al seguir tus instrucciones me manda lo siguiente:
    make: *** /lib/modules/2.6.32-5-686/build: No existe el fichero o el directorio. Alto.
    make: *** [modules] Error 2
    There was a problem compiling the package

    pero no se que es lo que pueda ser, me podrías asesorar?

    De antemano muchas Gracias
    Saludos
    Nota: Estoy utilizando Crunchbang

    • erickcion dice:

      Debes asegurarte de que tienes instalado en tu sistema las cabeceras del kernel, en tu caso debe ser el paquete “linux-headers-2.6.32-5-686″, si no las tienes no se podrá ejecutar el make (compilación del driver) correctamente.

      • Miguel dice:

        Buenas noches:

        Erick nuevamente molestando, ya logré instalar los “linux header”, volví a correr el script nuevamente, ahora me marca el siguiente error:

        /home/server/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/include/linux/compat-2.6.34.h:231: error: redefinition of ‘dma_set_coherent_mask’
        /usr/src/linux-headers-2.6.32-5-common/include/linux/dma-mapping.h:131: error: previous definition of ‘dma_set_coherent_mask’ was here
        make[5]: *** [/home/server/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/compat/main.o] Error 1
        make[4]: *** [/home/server/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/compat] Error 2
        make[3]: *** [_module_/home/server/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27] Error 2
        make[2]: *** [sub-make] Error 2
        make[1]: *** [all] Error 2
        make[1]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-686′
        make: *** [modules] Error 2

        Vi en los comentarios anteriores, que sugieres buscar el archivo 2.6.34.h y comentar o quitar la línea 231, y así lo hice, pero cuando vuelvo a correr el script, me arroja nuevamente el mismo error, es decir el script vuelve a modificar el archivo y lo deja como estaba originalmente, volviendo a dar el mismo error.

        Espero tus comentarios.

        Y de antemano, muchas gracias.

  63. fernando dice:

    Gracias erick opr la pronta respuesta, lamento decirte que aún no he tenido tiempo de probarlo, por el día trabajando fuera y cuando llegas a casa como que no hay muchas ganas de ponerse con quebraderos de cabeza, mañana a no más tardar me pongo con ello y ya te digo como ha quedado.

    Muchas gracias por todo y disculpa las molestias.

  64. fernando dice:

    Pues ni con el script, ni a pelo.. ni nada de nada, llega un punto que no se porque narices, no me deja.

    He bajado el script, le he dado permisos y una vez lo lanzo a ejecutar, me sale lo siguiente:

    /home/pilar/Desktop/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/include/linux/compat-2.6.34.h:231: error: redefinition of ‘dma_set_coherent_mask’
    /usr/src/linux-headers-2.6.32-5-common/include/linux/dma-mapping.h:131: error: previous definition of ‘dma_set_coherent_mask’ was here
    make[5]: *** [/home/pilar/Desktop/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/compat/main.o] Error 1
    make[4]: *** [/home/pilar/Desktop/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/compat] Error 2
    make[3]: *** [_module_/home/pilar/Desktop/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-686′
    make: *** [modules] Error 2
    There was a problem compiling the package.

    Si hace falta que copie toda la salida lo dices.. yo es que ya no se por donde tirar, los headers están instalados make también.. lo único que digo yo que puede ser, es que el portátil, tiene una wifi integrada, una intel kedron, lo malo de esta es que no soporta el protocolo tipo N y por lo tanto no me sirve, por eso haía comprado el tp-link, a ver si con tu ayuda puedo resolver el problema.

    Gracias de antemano.

    Pd- para tirar abajo la otra wifi por si acaso estuviese activa e interfiriendo con esta, como se hace?

    • erickcion dice:

      El problema que presentas parece ser solucionado por otro usuario que usa tu misma arquitectura del kernel y la mismas version del compat-wireless que va con el paquete…

      Echale un ojo a este hilo y nos cuentas:

      http://forums.debian.net/viewtopic.php?f=10&t=70450#p395616

      Por lo que comenta, el compat-wireless declara una función que ya existe en el kernel y lo que hizo fue buscar la linea y borrar dicha declaración.

    • erickcion dice:

      Para ayudarte un poco busca en este archivo:

      /home/pilar/Desktop/erickcion-tlwn722n-linux-install-8640e41/source/compat-wireless-2011-08-27/include/linux/compat-2.6.34.h

      La linea 231 y tratas de eliminar o comentar la declaracion de la función:

      dma_set_coherent_mask

      Nos cuentas come te fue.

      • buenas erickcion he intentando por todos los medios instalar le el usb wifi tlwn721n y hay fue como llegue a este foro.

        Quisiera saber si me puedes ayudar a resolver el problema ya que estoy parado en este punto y aun eliminando la función de la linea 231 del archivo compat-2.6.34.h me sigue pareciendo el mismo error de problema de compilación mostrado en el comentario de Fernando. Te agradezco de antemano tu valiosa ayuda

  65. Mydo dice:

    Hello Erick, I don’t speak Spanish (I do speak and write French and English). I am trying to install the drivers for my TP TLWN722N adapter following your tutorial(Google translation). But I am having error and the last error message is:
    There was a problem compiling the package.
    I am using Debian Squeeze and I am a new comer to Linux :)
    Can you specify well how I can get by installing the drivers? Thanks!

  66. Felipe Weiss dice:

    Muy bueno el manual!
    Sirvio!
    Muchas gracias :D

  67. frost dice:

    amigos segui todos los pasos pero m sale un error q dic algo asi q make no esta instalado la distro q uso s opensuse 11.4 … espero q m puedan ayudar a solucionarlo

  68. io tengo xubuntu y a la hora de poner su -c ./install.sh y pongo mi pass pero me sale fallo de autentificacion espero q me ayudes y si se puede hacer de otra manera que no sea consola porq io recien entro a esto de linux :)

    • erickcion dice:

      Hola alexander, En Xubuntu (o Ubuntu y sus derivados) deberías colocar:

      sudo ./install.sh

      Inténtalo así y nos comentas que tal.

      • alexander dice:

        hola erickcion , io lo que hice fue actualizar el xubuntu 10.04 a 10.10 y reconocio automaticamente el usb wifi pero iba muy lento y la señal se cortaba ai que segui los pasos que distes y utilice sudo y arranco de 10 la señal esta super buena y ia no tiene cortes gracias .

      • erickcion dice:

        Excelente, gracias por comentar.

  69. [...] Si quieres instalar este driver puedes ayudarte con este instalador. [...]

  70. francisco dice:

    Estimado, muy interesante el post y la ayuda , pero aun no puedo ejecutar pues me da un mensaje de Permiso denegado al entrar ./install.sh aun con su root -c. Perdon mi ignorancia,…alguna ayuda?

    • erickcion dice:

      Es común obtener un mensaje de “Permiso denegado” cuando el archivo no tiene los permisos de ejecución… para darle esos permisos escribe lo siguiente estando en la carpeta del script:

      chmod +x ./install.sh

      Luego intenta hacer el “su -c ./install.sh” y nos comentas. Voy a editar el artículo para colocar ese paso.

  71. antonio dice:

    WiFi TP-LINK TL-WN722N Muchas gracias todo perfecto en trisquel

  72. tonyvzla dice:

    Buenos diastengo canaima educativo, trato de hacer todo los pasos que se mencionan aca y me sale esto: bash: install.sh: no se encontró la orden, que sera que estoy haceiend mal? de antemano gracias por la ayuda

  73. Anthony dice:

    Buenos dias tengo canaima educativo, trato de hacer todos los pasos que tu sucitas aca y me da el siguiente error: bash: install.sh: no se encontró la orden, que debo hacer alli? o que debo estar haciendo mal? gracias por tu ayuda.

  74. jneyra dice:

    Encontre para el kernel 3.0, a ver si actualizas tu script :)

    http://www.orbit-lab.org/kernel/compat-wireless-3.0-stable/

    • erickcion dice:

      Jneyra, La versión de compat-wireless que introduje en el paquete es la que funcionó para mi distro y la mas actualizada para el momento, de todos modos si por alguna casualidad tu computadora tiene conexión a internet, el script tratará de descargar la versión mas actual.

      La mayor documentación para hacer el script la tome de acá: http://linuxwireless.org/en/users/Drivers/ath9k_htc y no mencionan ninguna incompatibilidad con el kernel 3.0, de todos modos usa la versión que mas se adapte a tu distro para que tengas mejores resultados.

      Por otro lado, hasta donde había escuchado, las versiones nuevas de Ubuntu reconocen este modelo de antena WiFi sólo al conectarlo, no lo he probado así que no puedo asegurarlo.

      Espero puedas comentarnos que tal te fue.

      • jneyra dice:

        Gracias por la respuesta.

        La version 11.04 de ubuntu si la reconoció como mencionas, sin necesidad de instalar nada. Mi instalación del 11.10 no fue desde cero, sino un upgrade de la 11.04 a la 11.10, quizás funcione con una instalación desde cero. No tuve tiempo de hacer pruebas (con LiveCD o Instalación Nueva), así que por ahora sigo con el kernel 2.6.38 y ubuntu 11.10 y con mi wifi funcionando.

  75. jneyra dice:

    Hola,

    Este script funciona para ubuntu 11.10, acabo de instalar ese ubuntu y me quede sin WiFi. El ubuntu 11.10 viene con kernel 3.0.0.2 y segun veo estos drivers solo funcionan con 2.6.x

    Gracias.

  76. erickcion dice:

    Cuentame mas detalles… cual es el modelo exacto de tu antena? que distro usas? no te funciona el instalador? enviame cualquier mensaje de error que te salga.

    • ricardo dice:

      tengo un problema espero puedas ayudarme tengo esta antena tl-wn722n y se conecta recibe una señal perfecta pero no recibe paquetes como puedo arreglarlo yo tengo windows xp y creo haber hecho la instalacion correcta de hecho ya probe de desinstalarla y volverla a instalar varias veces y no consigo otro resultado

  77. dnecrew dice:

    ayuda toy bien verde pa esto quisieras explicarme muy bien tengo la misma antena pero es v2

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 444 seguidores

%d personas les gusta esto: